Canvas Sluggish

Incident Report for SNC ITS

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 12:42 CST

Investigating

Users may experience slowness with and issues uploading files to Canvas.

We have engaged our Canvas support vendor to remediate this issue.
Posted Dec 11, 2025 - 12:09 CST
This incident affected: Educational Technology (Canvas).