DegreeWorks Inaccessible
Incident Report for SNC ITS
Resolved
Issues have been resolved.
Posted Apr 01, 2020 - 15:54 CDT
Investigating
We are currently investigating an issue related to logging into DegreeWorks.
Posted Apr 01, 2020 - 15:42 CDT
This incident affected: Enterprise Applications (DegreeWorks).