Service has been restored for all Data Centers as of 12:38 PM PT. Customers are now able to login and use the tenant as expected. There is no evidence that indicates any type of security issue or data loss of any kind.
We will continue to monitor this situation over the next 24 hours.
We are also seeing performance issues with the case management application causing it to either run slowly or be unresponsive which may impact your ability to run reports and update/create Support cases.
Posted Mar 17, 2025 - 15:10 CDT
Monitoring
It appears that access to the Workday tenants has been restored. We will continue to monitor to ensure everything remains stable and will mark resolved once we receive official confirmation from Workday that the issue has been identified and resolved.
We apologize for any challenges presented by this matter.
Posted Mar 17, 2025 - 14:50 CDT
Investigating
We have gotten reports that Workday is experiencing a service interruption and is currently unavailable to users. We will be monitoring the status and update this post as new information comes in.
Posted Mar 17, 2025 - 13:38 CDT
This incident affected: Enterprise Applications (Workday).