Printing
Incident Report for SNC ITS
Resolved
Problems with printing have been resolved. If you are still experiencing issues please contact the ITS Service Desk.
Posted Aug 22, 2022 - 09:30 CDT
Investigating
ITS has received reports of users unable to print. We are investigating this issue.
Posted Aug 22, 2022 - 08:28 CDT
This incident affected: Network (Printing).