Print by Email Unavailable

Incident Report for SNC ITS

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 13:21 CDT

Investigating

We are investigating an issue with the print by email method not displaying print jobs sent to the printthis@snc.edu account. As an alternative, users can sign into papercut.snc.edu and upload documents to the webpage to print off. We have a Knowledge Base article with these instructions if needed: https://servicedesk.snc.edu/hc/en-us/articles/360008235594-How-To-Print-SNC-Students-Faculty-and-Staff.
Posted Apr 28, 2025 - 16:05 CDT
This incident affected: Network (Printing).