Cellcom Outage - Outbound calling from campus phones to cellular numbers affected

Incident Report for SNC ITS

Resolved

This incident has been resolved.
Posted May 29, 2025 - 08:45 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2025 - 07:40 CDT

Investigating

Cellcom is currently experiencing a major outage affecting the ability to make outbound calls from campus phones to any cellular number. Inbound calls to campus extensions appear to be functioning normally. At this time, Cellcom has no ETA on restoration of services.
Posted May 15, 2025 - 07:37 CDT
This incident affected: Network (Telephones).