Printing
Incident Report for SNC ITS
Resolved
Printing problems have been resolved. Please contact the Service Desk if you have any further issues.
Posted Jan 16, 2024 - 12:03 CST
Investigating
ITS is aware of users having difficulties printing. We are currently working on the issue.
Posted Jan 16, 2024 - 11:33 CST
This incident affected: Network (Printing).