Workday Outage

Incident Report for SNC ITS

Resolved

This incident has been resolved.
Posted May 05, 2026 - 09:28 CDT

Investigating

Workday is currently experiencing a large-scale outage. Our instance of Workday is impacted.
Posted May 04, 2026 - 16:25 CDT
This incident affected: Enterprise Applications (Workday).