Workday Intermittent Performance Issues
Incident Report for SNC ITS
Resolved
Workday has put a solution in place and the issue is now resolved. You should see an improved performance when signing in and working within the system. We apologize for any inconvenience and sincerely thank you again for your patience and understanding.
Posted Mar 21, 2022 - 15:55 CDT
Update
Workday has put a solution in place and the issue is now resolved. You should see an improved performance when signing in and working within the system. We apologize for any inconvenience and sincerely thank you again for your patience and understanding.
Posted Mar 21, 2022 - 14:36 CDT
Investigating
Workday has alerted us that they are experiencing intermittent performance issues. We appreciate your patience and will update this incident as we receive additional information.
Posted Mar 21, 2022 - 10:51 CDT
This incident affected: Enterprise Applications (Workday).