DegreeWorks issues
Incident Report for SNC ITS
Resolved
This incident has been resolved.
Posted May 20, 2020 - 10:21 CDT
Monitoring
Degree Works is now available. We'll continue to monitor to make sure that things are stable.
Posted May 20, 2020 - 09:12 CDT
Update
We are continuing to investigate this issue.
Posted May 20, 2020 - 09:11 CDT
Investigating
Degree Works is currently unavailable. We are investigating the issue.
Posted May 20, 2020 - 08:56 CDT
This incident affected: Enterprise Applications (DegreeWorks).