Workday Mobile App and Dashboard Outage

Incident Report for SNC ITS

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 16:05 CST

Investigating

The Workday mobile application is experiencing an outage right now.

There is also an issue loading the dashboard page when navigating to Workday via web browser on a computer or mobile device. Other functions withing Workday are functioning appropriately.

During this outage, we'd recommend navigating Workday from a computer, and accessing Workday's applets from the global navigation column on the left side of the web app.
Posted Dec 09, 2025 - 14:53 CST
This incident affected: Enterprise Applications (Workday).