Lockdown Browser Issues

Incident Report for SNC ITS

Update

Respondus is aware of the issue and is active working with Instructure. Testing shows that exams that already have LockDown Browser or LockDown Browser+Webcam enabled are unaffected. Students can proceed. More info.: https://support.respondus.com/hc/en-us/articles/49831405234971-LockDown-Browser-Dashboard-Error-for-Canvas
Posted May 01, 2026 - 09:40 CDT

Investigating

We are currently experiencing an issue with Respondus LockDown Browser that is generating error messages for some users. Our team is actively investigating the problem and working to identify a resolution as quickly as possible.

We will provide updates as more information becomes available.
Posted May 01, 2026 - 08:40 CDT
This incident affected: Educational Technology (Respondus LockDown Browser).