Canvas - Slow Load Time

Incident Report for SNC ITS

Resolved

Canvas has implemented a fix and will continue to monitor but the SNC instance of Canvas appears to be resolved.
Posted Aug 31, 2026 - 17:11 CDT

Update

Canvas is aware of the issue and is investigating. Updates can be found at https://status.instructure.com/
Posted Aug 31, 2026 - 13:05 CDT

Update

We are continuing to investigate this issue.
Posted Aug 31, 2026 - 12:57 CDT

Update

We are continuing to investigate this issue.
Posted Aug 31, 2026 - 12:54 CDT

Investigating

Canvas is experiencing slow load times. We are actively working with our vendor to investigate.
Posted Aug 31, 2026 - 12:53 CDT
This incident affected: Educational Technology (Canvas).