Unable to Dial Outside Numbers

Incident Report for SNC ITS

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 09:47 CDT

Investigating

We have gotten a few reports of users unable to place calls to off campus numbers. We are currently checking with our vendor on this issue and will update this incident as soon as we can.
Posted Aug 04, 2025 - 09:00 CDT
This incident affected: Network (Telephones).