Qualtrics - Login Problem
Incident Report for SNC ITS
Resolved
We have swapped authentication providers to Okta for Qualtrics.
Posted Nov 21, 2024 - 13:15 CST
Investigating
We are aware of an issue where people cannot properly login to our Qualtrics instance, snc.qualtrics.com

We have a way to workaround the problem. Please reach out to the Service Desk for assistance.
920-403-4040, or email servicedesk@snc.edu
Posted Nov 19, 2024 - 18:11 CST
This incident affected: Educational Technology (Qualtrics).