TouchNet360 Mobile App - Fix Available
Incident Report for SNC ITS
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 06:26 CDT
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2024 - 11:55 CDT
Monitoring
Good News! A fix has been implemented for the issues that have been preventing the TouchNet360u app from working properly. All users that currently have the app on their phones need to update to the latest version via the App Store (Apple) or Google Play Store (Android) respectively.
Posted Apr 04, 2024 - 11:54 CDT
Investigating
We are currently experiencing and issue with the TouchNet360u mobile application. The vendor is aware of the issue and is currently looking into it. We will update status with more information as soon as we are able.
Posted Mar 26, 2024 - 19:05 CDT
This incident affected: Enterprise Applications (OneCard).