Printing
Incident Report for SNC ITS
Resolved
Issues affecting printing have been resolved. If you encounter further problems, please contact the ITS Service Desk.
Posted May 18, 2022 - 13:02 CDT
Investigating
ITS has received reports that users are unable to print. We are currently investigating the issue.
Posted May 18, 2022 - 12:48 CDT
This incident affected: Network (Printing).