Unable to sign into Laserfiche Cloud

Incident Report for SNC ITS

Resolved

A fix has been implemented and user should be able to use Laserfiche.
Posted Nov 15, 2022 - 11:09 CST

Investigating

Laserfiche is reporting an issue preventing users from signing into Laserfiche Cloud. They are currently investigating the issue. We will keep track of their status and provide updates here.
Posted Nov 15, 2022 - 10:07 CST