Phone System Outage

Incident Report for SNC ITS

Resolved

Issue has been resolved working with our carrier.
Posted Aug 17, 2026 - 17:21 CDT

Investigating

We are currently experiencing an outage related to incoming and outgoing calls from and to off-campus numbers.
Posted Aug 17, 2026 - 15:06 CDT
This incident affected: Network (Telephones).