Printer maintenance extended
Incident Report for SNC ITS
Resolved
This incident has been resolved.
Posted Sep 22, 2020 - 22:38 CDT
Update
We have completed the schedule printer maintenance. Full print functionality has been restored.
Posted Sep 22, 2020 - 20:41 CDT
Investigating
While our recent printer maintenance has completed, functionality has not yet been restored. We are working to restore printing functionality.
Posted Sep 22, 2020 - 18:49 CDT
This incident affected: Network (Printing).