DegreeWorks Connection Issues
Incident Report for SNC ITS
Resolved
DegreeWorks is now back online. If you experience any further issues, please contact the ITS Service Desk.
Posted Feb 13, 2020 - 15:41 CST
Investigating
We are currently investigating an issue preventing users from logging into DegreeWorks.
Posted Feb 13, 2020 - 15:20 CST
This incident affected: Enterprise Applications (DegreeWorks).